
AN INTRODUCTION TO FRONTPAGE 2000



Purpose:

To provide an introduction to 
FrontPage 2000, a Web page design 
and Web site development tool.  

Benefits of FrontPage 2000:

• Create new Web pages easily

• Revise existing pages 

• Manage a Web site 

without HTML programming!



Getting Started
Launching FrontPage:
Open FrontPage 2000 by either double 
clicking on the FrontPage Icon or by selecting 
the program from the Start Menu.

Its on the desktop.

Understanding FrontPage Anatomy:
When you launch FrontPage you will see the Main 
Window, with a blank page

Page View: 
WYSYWIG Window

for creating web
pages

Folders View: 
View all files,

images, etc.  Drag & 
drop pages into 

folders

Reports: 
Quick overview of

site areas.
Identifies broken or 

unverified links

Navigation: 
Organizes pages

in your site

Hyperlinks: 
Graphical 

representation
of links

Click here to 
preview your 
page

Click here to see
HTML code



Opening a New Web : From the File Menu, select New 
Web. This will launch a new dialog box that lists several 
wizard and template choices. For this exercise select "ONE 
PAGE WEB".

Explanation:
The templates are listed in the window on the left side of the 
screen; a description and preview of each appears on the right side 
of the dialog box. When you decide on a template, FrontPage 
creates a page using the template you select and then presents it in 
Page view for you to work on. The Page view presents pages in 
WYSIWYG (What you see is what you get) format. In other 
words, what you see in Page view is what you or the web audience
will see when viewing your page using a web browser. The Page 
view works much like a word-processing application (MS 
Word). Many of the formatting buttons and commands found in 
Word are also included in this program.



Giving a Title to Your Page: One of the first tasks 
when creating a Web page is to provide a title. The title 
will be displayed in the upper most bar of the Web 
browser. To title your page, place your mouse inside the 
Page view window and right click once. Select Page 
Properties. This will generate a new dialog box (see 
below). Type in a title for your page in the appropriate 
text box, then select OK

Setting the Background color… it is recommended that 
you set the background color as white – NOT Automatic.  
This will help your pages look consistent throughout the 
Web site

The Web page title will appear at the very top of window in an Internet 
Browser and are not seen in the actual Web page.



Using Shared Borders: If you would like to have a logo 
or set of hyperlinks appear at the bottom of every page on 
your Web you do not have to add it to each page. Instead 
you can use a shared border at the bottom of the page 
which will display the same information of every page in 
your Web.

To insert shared borders: select the Shared Borders from 
the Format menu on the Tool bar. This will open the 
Shared Boarders dialog box. You can specify whether 
you want to include the shared borders on all pages in 
your Web or just the current page. You also have the 
option of displaying borders along the top, bottom, right 
and left margins. The check boxes under the Top & Left 
borders give you the option of displaying Navigation 
buttons. Select the options pictured below:

Check these boxes



Applying a Theme: FrontPage has designed professional 
looking graphics including buttons, banners, backgrounds and 
text that help to control the consistency of your Web 
pages. You do have the ability to modify each component 
within a theme. To select a theme click on the Format menu 
and select Theme. This will open the Theme dialog box.

•The Theme dialog box gives you the option of applying the 
theme to all the pages in the Open Web or to just the Selected 
page.

•To Modify the theme, click on the Modify button. This will 
allow you to change the background image, the color of the 
hyperlinks, font etc.



Formatting Text, Headings and Paragraphs:
Adding text to a page is as simple as typing it into the Page view 
window. Another method is to copy text from another MS Office 
document such as a Word file or Excel spreadsheet and paste the text 
directly into your FrontPage window. The text is automatically converted 
into HTML. Or, you can insert files into the Page view by using the File 

command on the Insert menu.

In the largest area of the page you will begin to type your page
content. Formatting your text in FrontPage is similar to formatting 
text in an MS Word document.

Type the title of your page. For example: "Instructional 
Technology". Highlight the text by dragging your cursor over the 
text you just typed. From the Style drop-down list on the Formatting 
toolbar, choose Heading 1. Notice there are six levels of headings 
in the list as well as several other formatting choices.



Creating a Paragraph: A new paragraph is established 
every time you select the "ENTER" key on your 
keyboard. The HTML tag for a paragraph is <P>. It 
is possible to format the alignment of paragraphs by 
right clicking on the text.

Type a short paragraph then right click, select 
"paragraph" and change the alignment (center, 
right, left, justify).

Add a new line of text within a paragraph (Line 
Breaks): To add a new line of text to the current 
paragraph, insert a line break. The text will appear at 
the beginning of the next line, but is still included in 
the previous paragraph. Lines that are separated with 
line breaks are not displayed with space between 
them, so these lines of text will appear close together 
(single spaced). The HTML tag for a line break is 
<BR>

1. In the Page view, position the insertion point where 
you want to insert a line break.

2. On the Insert menu, click Break.

3. Click Normal line break.

This is useful when you want to enter your name, address 
and phone number.

For Example:  

RECAP Planning Committee
Anderson Hall

West Chester University
recap@wcupa.edu

mailto:recap@wcupa.edu


Inserting Horizontal Rule: Horizontal lines are used to 
separate content on a Web page. To insert a Horizontal 
line, Select Horizontal Line from the Insert
menu. Double clicking on the line will allow your to format 
the size, the alignment and the color.



Saving Your Page for the First Time: While there are 
several commands that you may use to save your Web page, 
all will generate the Save As dialog box. Click either the 
Save icon      or Select Save As from the File menu. Change 
the default page title by typing the File name into the text 
box.
NOTE: Use lowercase letters for all filenames. Standardize on a naming convention for 
the filenames so that they reflect the content of the files. The organization's first page 
should be named "index.htm." Be consistent in and with extensions. Do not include special 
characters (e.g., @, !, %, &) or spaces in naming of the files or directories. Use of 
underscore ( _ ) or dash ( - ) is advisable instead of special characters. 

Change file name

create a folder to organize
your pages & images

This page will become your Home Page.



Saving Images: When you save your page, FrontPage will 
automatically look for any saved embedded files such as 
pictures/graphics and generate a dialogue box allowing you to 
save these images in a designated folder.  It is best to set this 
image folder when you save your page for the first time.



Using Tables to Format your Pages

Tables are a useful tool to help present information that is 
organized and visually appealing. Tables allow you to control the 
layout of your page and can be used to provide consistency 
throughout your Web pages regardless of the Internet browser a 
user may have. While you can open the Table toolbar from the 
View menu, I generally use the Table, Insert option from the the
Standard toolbar      . By dragging your mouse cursor over the 
grid you can determine the number of rows and columns you'd 
like in your Web page.

Tip:  Often you will want to have a picture next to text.  Use tables to 
keep everything in its place.



Choose the insertion point for your table

1. Select the table icon      then select a table that is 
1x2. This will give you a table that is 1 row with 
2 columns.

2. Formatting the table can be accomplished by 
placing your mouse cursor inside the table and 
right clicking.

INSERT TEXT 
HERE

INSERT IMAGE 
HERE

Select "Table Properties" to open the Table's 
Properties dialog box. Here you can define the 
size of the table borders, the alignment of the 
table, etc.



Formatting Cell Properties

The size of the table can be changed by specifying the 
width and height in the Table Properties box.
Text inside of the Table cells can be formatted using the 
Formatting tool bar
Right clicking inside a cell and selecting "Cell 
Properties" opens the Cell Properties dialog box which 
allows you to define the text alignment within the cell, i.e. 
Horizontal Alignment can be set to Left and Vertical 
Alignment can be set to Bottom or Top.



Images and Graphics

Adding Images: There are two standard graphic file 
formats used in Web page development: CompuServe 
GIF (GIF) and JPEG (JPG). GIF files are a 
compressed format for images that contain 256 or less 
colors (logos, clip art). JPEG files are most suitable 
for photographs or images that contain more than 256 
colors. FrontPage can import many other graphic file 
formats such as Bitmaps (BMP), TIFF (TIF), Ping 
(PNG). When you save a page that contains images 
that are not JPG or GIF files, FrontPage will ask if you 
want to save each image to the current Web. By 
default, FrontPage will save these files as a GIF.

Instructions for inserting images from MS Clip Art Gallery
1. In the Page view, position the insertion point where you 

want to insert a picture
2. On the Insert menu, click Picture, then select Clip Art
3. Select an image from the Clip Art Gallery by clicking on 

the image
4. Click "Insert Clip"
5. Save your page (Front Page will ask where to save the 

images in your page. It is highly recommended that you 
save all images in a folder called "images")



Instructions for inserting images from other files

1. In the Page view, position the insertion point where 
you want to insert a picture

2. On the Insert menu, click Picture, then select File

3. FrontPage will open a new dialog box for you to 
locate your image file

4. If the image you want is already in your FrontPage 
image folder simply select it from the window or 
browse another web using this icon       .

5. If the image you want is located on your C:/ or on 
your A:/ you will need to click the browse icon        .

Formatting Images: Often the image you insert into your Web page will 
need to be resized or re-aligned. There are many ways to format images, 
however the easiest way is to simply click on the image and use the 
arrows to resize the image. Alignment can also be adjusted by selecting 
the image and then using the Formatting toolbar. Images can also be 
dragged to a new location. Please notice that when the image is selected 
the Picture toolbar appears at the bottom of the screen. Place your 
mouse over each icon to view the commands.



Alt Tags for Images & Animations

ALT Tags: To increase universal access of Web 
information it is necessary to insert "Alternative 
Representations" or "ALT Tags" which describe the 
function of each visual. To do this, right click on the 
image and select Picture Properties. In the Picture 
Properties dialog box locate the Alternative 
Representation Text box and type in a few words to 
describe the picture. For example, if you have a logo 
on your page the ALT Text should read “West 
Chester University Logo".

Type description 
of images here



Using Hyperlinks 

Links: Hyperlinks are connections from one point to 
another. We will be discussing two types of links, Internal and 
External.
• Internal links allow web users to jump to another place 
within the Web page. A common example of an internal link is 
BACK TO TOP.
• An external link will take a user to another Web page.

To create an Internal link, you must first create a bookmark or an 
anchor.

Creating a bookmark & internal hyperlink
1. Select the text or image that will become the 

bookmark (the text you want to jump to).
2. From the Insert menu, click Bookmark. The Bookmark 

dialog box appears.
3. Enter a name for the bookmark
4. Click OK

Next, you will create an internal hyperlink that will connect one 
place on your page to the bookmark you just named.
1. At the top of your page highlight the text or image you 

want to link from
2. Choose Hyperlink from the Insert menu or press Ctl+K

or right click on the mouse and choose Hyperlink
3. Select the Bookmark from the Optional Bookmark 

drop-down box
4. Select OK



Creating an external link requires that you know the URL (Uniform 
Resource Locator) or the address of a page.

1. Highlight the text or image you want to link from

2. Choose Hyperlink from the Insert menu or press Ctl+K
or right click on the mouse and choose Hyperlink

3. Type in the WWW address of the page you would like 
to link to, or if you want to link to another Page in your 
Web highlight that page from the dialog box.

4. Select OK

Type Web 
address here

Search for a web 
page here

Select a set 
Bookmark here

Tip:  To test your link you will need to Save your Page and 
then switch to the Preview mode or Click on the "Preview in 
Browser" icon   from the Standard toolbar.



Site Navigation: One of the most important components of your 
Web site will be its navigation. Most web developers place 
navigation buttons on all pages within a site. We will be using 
the Navigation view in FrontPage to provide a visual 
representation of our sites structure.

1. Add a new page to your site by selecting the new page icon   
on the Formatting Toolbar.

2. Save this new page. (i.e., page2.htm) You will see it added to the 
Folder List

3. Select this new page (i.e., page2.htm) from the Folder List and 
drag it to the Navigation View.

4. Drop the file under the Home page (default.htm)

5. The title of the page will be displayed on the Navigation 
bar. You can rename your page by Right Clicking on the 
rectangle, or selecting Page properties in the Page view.

6. Shift back to the page view by either selecting PAGE or double 
clicking on the rectangle.

7. Define the Navigation Bar properties by right clicking in either
the left or top shared border and selecting Navigation Bar 
properties.



8. This will open the Navigation Bar dialog box which offers a 
variety of options. You have the option of selecting either 
buttons or text to represent your navigation bars. You will 
also select which pages to include in the navigation 
bar. Select the following:

You have the option of modifying your navigation bar by selecting the 
Navigation Bar Properties box. Or you can modify/change the theme 
you have selected. You may need to experiment with different settings 
to find which Navigation Bar works best for your site.



To insert a Page Banner:

Click on the Insert menu, select Page Banner

Select Picture

The result will look something like this:



Checking Your Work

When you have completed your pages, 
please ask yourself these questions:

1. Have I proofread the pages for spelling, grammar, and 
punctuation errors?

2. Have I confirmed the information on the pages is accurate?

3. Do my pages have a consistent look & feel (e.g., white 
background)?

4. Have I included the ALT tags for images?

5. Have I used images that are easy to load using a 28.8 K 
modem?

6. Have I looked at my documents on a monitor set to 640 x 480 
resolution?  800 x 600 resolution?  1024 x 768 resolution?  
1280 x 1024 resolution?

7. Have I followed every link accessed by my document?

8. Have I looked at my documents using different Internet 
browsers (Internet Explorer, Netscape)?  Using different 
operating systems (Mac, Windows)?



SUMMARY

FrontPage 2000 is a Web page editor that allows Web designers to create 
simple or sophisticated Web pages without knowledge of HTML.

FrontPage 2000 is available to West Chester University Faculty and 
Staff by contacting the Office of Information Services ext. 3191

Content is king, but Navigation is key to not confusing your audience.

TEST your pages on various Internet Browsers (AOL, Netscape, 
Explorer) and Operating Systems (Windows, MAC).

Web Resources:
Important information for publishing your Web pages on the West Chester 
University Web Site
http://www.wcupa.edu/infoservices/WEBINFO/publish/

HTML Validators
http://www.flfsoft.com/html/html_validators.html

http://validator.w3.org/

ADA Web Authoring Resources
http://www.cast.org/bobby/

http://aware.hwg.org/

http://www.w3.org/WAI/References/

http://www.wcupa.edu/infoservices/WEBINFO/publish/
http://www.flfsoft.com/html/html_validators.html
http://validator.w3.org/
http://www.cast.org/bobby/
http://aware.hwg.org/
http://www.w3.org/WAI/References/

