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IMPORTING TEXT FILES

1. Click the Data tab, select From Text
2. Locate the file and click import
3. The Text Import Wizard will appear

Text Import Wizard

1. Choose the file type that describes your data. If you are unsure of the type leave the default
settings > Click Next

1 Delimited i information separated by characters such as commas or tabs
1 Fixed with T information separated by spaces between each file

Text Import Wizard - Step 1 of 3.

The Text Wizard has determined that your data is Delimited.

If this is correct, choose Next, or choose the data type that best describes your data.
Original data type
Choose the file type that best describes your data:

(® Delimited - Characters such as commas or tabs separate each field.
(O Fixedwidth - Fields are aligned in columns with spaces between each field.
Start import at row: 1 2 File origin: | 437 1 OEM United States v

Preview of file C:\Documents and SettingsitthomasiMy Docum...\Managing data XP.txt,

PankOSexOFirst NameOLast Name OSalaryODepartment
Bssociate Professor0F00prah0Winfrey 0"$50,000.00"0Conmunicationy = |
bssociate Professor0F0GwenOStefaniO"$56,22Z.00"0Vocal

bssociate ProfessorOMIMichealOJordanO"$89,000.00"0Athletics
bssociate ProfessorOMOBillOCosby0"$56,000.00"0Conmunications

| >

< Ba I Next > I[ Finish ]
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2. Select the delimiter(s) your data contains, if you are unsure leave the default. > Click Next

Text Import Wizard - Step 2 of 3

This screen lets you set the delimiters your data contains. You can see
how your text is affected in the preview below.

Delimiters
Tab [] semicolon [[] Comma

[[space  [] other: D Text gualifier: " vi

[] Treat consecutive delimiters as one

Data preview

[Pank Fex [First Name [Last Name [Salary Departm ]
hssociate Professor [F Dprah Minfrey F20,000.00 Communif —
Lssociate Professor [F Gwen Prefani F56,222.00 Nocal
Bssociate Professor M Micheal Hordan F89,000.00 Bthleti
Bssociate Professor M Bill Cosby F56,000.00 Communi{ .,
< ‘ |

[ Cancel ][ < Back ][ MNext = ][ Finish ]




3. Select a format for each column. To select a column, click on the column headers

Text Import Wizard - Step 3 of 3
This screen lets you select each column and set Column data format
the Data Format, (3 General

‘General’ converts numeric values to numbers, date O Text
values to dates, and all remaining values to text. O pate: MDY v

) Do not import column (skip)

Data preview

sxfensral  Leperal  Peneral — GenerallW~
First Name [Last Name alary Departnm ﬁ
Dprah Minfrey $90,000.00 Communi{ - Column Headers
Gwen Prefani FS6,22Z2.00 Wocal
Micheal Hordan FS82,000.00 fthleti
t Eill Cosby FS6,000.00 Communif.,
< | >

[ Cancel ][ < Back ]

4. Click Finish
5. Select where you want to place your data

g Import Data lur

Where do you want to put the data?
@ Existing worksheet:

| =5A$1

() New worksheet

[P;operﬁes...] [ OK ] [ Cancel J




CREATING A TABLE

When creating a table in Excel keep the following in mind.
1 Create the table on one spreadsheet

1 Create column headers at the top of each column
a. Inthe example below the column headers are: Rank, First Name, and Last Name
Note: Try not to leave any blank rows or columns but you may have blank cells.

A B [
1 |Rank First Name Last Name
2 Associate Professor Oprah Winfrey
3 | Associate Professor | Gwen Stefani
4 |Agsociate Professor Micheal Jordan
5 |Associate Professor Bill Cosby
G | Doctor Robert Redford
7 Dactar Salma Hayek
5 Doctor Jules Asner
9 Doctaor hlatt LeBlanc
10 |Professor F Diddy
11 |Professor Sandra Bullock
12 |Professor hlatt Diarnon
13 |Professor Jeff Soldblum

Range: Two or more cells on a sheet. The cells in a range can be adjacent or nonadjacent.

Table: A series of rows and columns that contains related data that is managed independently from
the data in other rows and columns on the worksheet.

Creating a table from predefined data
1. Select the contents of your range
2. Select the Insert Tab > Select Table in the Tables group
3. Click OK to the Create Table box

Create Table ‘L&

Where is the data for your table?

|| My table has headers

OK ]1 Cancel }

[S 4

Creating a new table
1. Select the range of cells to be included in the table
2. Click the Insert Tab > click Table in the Tables group
3, Clle Ok ’Crc-ateTabIe (21 %=

Where is the data for your table?
=SAS19:SES32

E3)

|¥] My table has headers

[ OK ]| Cancel ]

[ 4

Note: You can create multiple tables on one spreadsheet
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Design Tab

This tab will only display when a table is active.

Table Name:

[i3] Summarize with PivotTable

Tablel }'Remove Duplicates

4”_} Resize Table [ .:j'_] Convert to Range

|

Properties Group:

[
|

P

Export Refresh

TABLE MANIPULATION

[ First Column

[ Last Column

[¥] Header Row
[T Total Row

RRERE EEEEE 4

‘ [¥] Banded Rows [[] Banded Columns ||
|

1 Table Name: Give the Table a name if you plan to use it in future formulas
1 Resize Table: Add/Remove columns and rows

Tools Group:
1 Summarize with PivotTable

1 Remove Duplicates- Remove duplicate rows from a sheet

1 Convertto Range i Converts table into a normal range of cells

Table Style Options:

1 Header Row

1 Total Row

i Banded Rows

1 First Column

1 Last Column

1 Banded Columns
Table Style

1 Change the color styles of the table

Total Row
This row provides access to summary functions so that you can quickly calculate your data.

Turning on the Total Row

H | J K I M
1. Select the last row of your table [Fall  BlWinter B Spring ) Summer B
2. Right-Click in the last row > Click Table > Click o o — o
Total Rows 46 34 67 100
20 32 78 78
98 56 89 88
86 67 aial <12 <JA A S % 2 F
61 48 BIED-> A -4AE
78 12 o =
78 23 % cut
53 Copy
fall B winter _Ed etei
Insert »
Delete >
Select >
Clear Contents
Sort >
Filter »
(2] Totals Row Table >
Conyert to Range | Insert Comment
f  Format Cells...
Pick From Drop-down List...
&, Hyperlink...




AUTO FILL

Use the Auto fill feature to fill cells with data that follow a certain sequence.

Numbers
Auto filling a sequence of numbers:
1. Type the first two numbers in the sequence
2. Highlight those two numbers
3. Click the Auto fill handle (lower right hand corner of the cell) and drag down

Auto filling a series:
1. Type the first couple of characters of the sequence.
2. Hold down the control key on your keyboard and the Auto fill handle then drag down

Dates
Auto filling a sequence of dates:
1. Type in the first date in the sequence
2. Click on the Auto fill handle (lower right hand corner of the cell) and drag down

Auto Fill handle

Custom Lists

Click the Office Button > Click Excel Options

Click Popular

Under Top options for working with Excel, click Edit Custom Lists

Click in the List Entries section and type your list, hit enter after each entry
Click Add

Click Ok twice

OuhsWNE



SORTING & FILTERING
Sorting:
Sorting one column
1. Click the down arrow, located in the column header, of the column to be sorted
2. Select the Sort order, ascending (a-z) or descending (z-a)

Sorting multiple columns - You can sort up to 64 fields at one time

Click the Data tab > in the Sort & Filter group click Sort

Click Add Level to add additional levels

Under Column select the fields you want to sort

Under Sort On select one of the following: values, cell color, font color, cell icon
Under Order select the sort order, ascending (a-z) or descending (z-a)

arwnE

“Sort olbe 2] = |

e
/] Add Level H X Delete Level “ 53 Copy Level ” : My data has headers

Column Sort On Order

Sortby |Rank E] Values E] AtoZ E]
v

Then by Department E] Values E] AtoZ

oK ] [ Cancel




Filtering:
1. Click the down arrow in the column that is to be filtered
2. Check off the condition you want to filter
1 Depending on the size of your list it may be better to check off t h eeleft 8llooption first
then select your filter criteria.
1 You can filter more then one field.
3. Click Ok

@ EXCELList.XLS [Compatibility Mode] - Microsoft Excel Table Tools
Home Insert Page Layout Formulas Review View Developer Add-Ins Get Started Design

";; J " : ‘ . [ “@ l@Connemons _21 EE ‘ ? & Clear :_i'-_":’ E*E 5 LE. ggi?

i Properties | "% Reapply —
From From From From Other Existing Refresh %l Sort Filter 7, Textto Remove Data Consolidate What-
ce %7 Advanced || Columns Duplicates Validation ~ Analysit

Access Web  Tex S Connections All = Edit Links

Professor
4l pm— B C D E F G H [ 1
@ Rank (&4 FirstName B3| LastName B3| DateofHire 8]  Salay B3 Gender B3 Dept. B3|
‘%l SortAtoZ Thomas 5/3/1984 200,000 F Computer
z Brothers 5/6/1987 76.000 F Health
| sortztoA - =l
A > Winfrey 6/1/1988 75.000 F Communications
Sort by Color 4 Applegate 5/3/1989 72,500 F Health
N ) . . Wars 6/1/1997 75.000 B Astrology
W Clear Filter From "Rank e $/1/1999 90,000 F Health
¢ Ly Zeta-Jones 8/1/1999 92,000 F Geology
Text Filters » Hanks 5/1/2000 70.000 M Drama
1 Downey Jr. 1/10/2001 75.000 M Health
V| | (select Al , Ford 1/1022001 75.000 M Foreign Language
[[] Associate Professor
Doctor
[IProfessor
“-[] (Blanks)

[ OK ][ Cancel ]

627
63

Example: The above example has all Doctors filtered out of the list.

Custom Filters:

1. Click the down arrow in the column you want to filter

2. Select Text Filters or Number Filters (this will depend on what you are trying to filter)
3. Enter the parameters for your filter

Custom AutoFilter X

Show rows where:

Salary

f equals v l E v ]
®and Oor

\ ¥ | v|

Use ? to represent any single character
Use * ta represent any series of characters

[ OK ][ Cancel ]

Turn off the filter:
1. Click the down arrow in the column where the filter has been applied
2. Select Clear Filter



DATA VALIDATION

You can use data validation to define restrictions on what data can or should be entered in a cell.

Adding Data Validation to a cell
1. Select the cell you want to validate
2. Select the Data Tab and in the Data Tools Group select Data Validation

Settings Tab
1. On the Settings tab, under Allow, select the type of criteria you want to allow in the cell. Under
Data enter in the excepted values

T o]
Data Validation li,il
Settings | Input Message ] Error Alert |
Validation criteria
Allow:
Whole number B [¥] 1gnore blank
Data:
between EI
Minimum:
Maximum:
[] Apply these changes to all other cells with the same settings
Clear Al ] [ OK ] [ Cancel
2. Click Ok

Data validating from an existing list
1. Select List under the Allow box
2. Type your values in the source box, placing commas after each selection OR if you currently
have a list in your worksheet, go back to the worksheet and select the list

Input Message Tab- Used to create helpful messages for validated cells.

1. Type in a title for the message
2. Type in a message, your message should indicate a reason or a brief explanation for the
validation or restriction

Data Validation ? XS

-

‘ Settings | InputMessage | Error Alert ‘

[¥] Show input message when cell is selected

When cell is selected, show this input message:
Title:

Input message:

OK ] [ Cancel




Error Alert Tab - Used to create an alert when invalid data is entered.

Data Validation li.i‘

|

‘ Settings I Input Message | Error Alert

[¥] show error alert after invalid data is entered

When user enters invalid data, show this error alert:
Style: Title:

Stop E]

Error message:

‘8

| Clear All OK |[ Cancel

1. Select your style
a. Stop i Allows the user to select Retry or Cancel

b. Warning i Allows the user to click Yes to accept the invalid entry, No to edit the invalid
entry, or Cancel to remove the invalid entry

c. Information 7 This is the most flexible alert, this allows the user to click OK to accept
the invalid value or Cancel to reject it

2. Enter atitle and an error message



DATA MANIPULATION FUNCTIONS

Concatenate Function xJoins several text strings into one.

1. Select the cell were the consolidate date will be entered
2. Click the Formulas tab i select Text T select Concatenate

3. In the Function Arguments window, click in the Textl box and enter the cell reference for the
first part of the string and in the Text2 box enter the cell reference for the second part. You
can add up to 255 text strings.

a. You must specify any spaces or punctuation that you want to appear in the results by
using quotation marks in the appropriate Text box.
Ex:

The quotes supplied put a space
between first and last text string. /

- -=o

~ -
Il

4. Use the Fill Handle in the lower right hand corner of the cell to apply the function to the

remainder of the list. 3
B — Auto Fill handle

10



