


































































































Working with Links

When a visitor clicks on a link, they are taken to the specified page or file. You can link text and images to:

A web page on your site or another web site

A specific location on a web page called a Named Anchor or Section Anchor.

A file such as a Microsoft Word or PDF document

An e-mail address that causes a new e-mail message to be generated, addressed to that e-mail address

If you have worked with other HTML editors such as Dreamweaver, FrontPage, or GoLive, you will notice that Contribute
handles links a little differently. You are required to select the type of link before you insert it so that you can take advantage of
the methods that Contribute provides for selecting the page or file to link to.

Adding and Modifying Named or Section Anchors

Before we get into a discussion on how to create links, it's important to understand a special type of link called a Named
Anchor or Section Anchor. After placing an anchor in a page, you can link to that location on the page, rather than linking to
the top of the page. This is especially useful for long pages and pages that are divided into several sections.

To insert a Section Anchor:

1. First place your cursor where you want the anchor to be placed
2. Select Insert > Section Anchor or press Ctrl-Alt-A on the keyboard. The Section Anchor dialog now appears:

Section Anchor Name: [anchorame]
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The Section Anchor dialog box.

3. Enter a name for the anchor. The name must begin with a letter and contain no spaces. There must be no other
anchors with the same name on the page.

Now click OK, and a flag graphic will appear on the page where the anchor is located, as shown.
|l-
A Section Anchor as seen in Edit Mode
To edit a Section Anchor's name, do one of the following:

e Double-click the flag graphic
+ Select the flag graphic, right-click, and select Anchor Properties
e Select the flag graphic, and select Format > Anchor Properties from the menu

Adding a Link

You can add a link to an existing block of text or image (such as a button) or place the cursor where you want the link to begin
and assign link text using the Insert Link dialog box. If you include text or an image in your selection before bringing up the
dialog, there will be no box to enter the link text. Instead, you will see an indication that the link will be placed on the selection, or
a grayed out box with the text you selected.

To open the Insert Link dialog box, make a selection or place the cursor where you want the link to begin and do one of the
following:

o  Click the Link button on the toolbar
e Select Insert > Link from the menu
e Right click and select Insert Link



Now select the type of link that you wish to insert:

A draft page or a recently published page. (Contribute keeps track of the 10 most recently published pages)

A new page. Contribute will create the new page for you. We saw this earlier when we discussed adding pages

An existing page that you will browse to

An e-mail address. This will create a link that will start a new e-mail message to the specified address when clicked

A file on your computer. The file will be placed in a folder on the web site when the page is published. If it is an image,
it will be placed in the /images subfolder of the folder containing the draft page. If the file is a document, Contribute will
place it in the /documents subfolder. If the necessary folder does not exist, Contribute will create it for you

Once you have opened the Insert Link dialog, you can change your mind about the source of the link.

Drafts and Recent Pages

In this case, we have elected to add a link at the insertion point to a Draft or Recent page:

Insert Link
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| Aboul with tables " Current Page

“ | |@ Our Company - Welcome Page Draft
[@ Our Company Support Published
[@ Our Company - Welcome Page Published

Inserting a link to a draft or recent page.
Notice that you can click on one of the other types of links in the top bar if you change your mind.

Contribute provides a list of current draft pages and up to 10 recently published pages. When you highlight a page on the list, a
preview will appear in the preview box. When you have selected the page you want to link to, click OK.



Create a Link to a New Page

Follow the same procedure we discussed in the Creating New Pages section:
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Inserting a link to a new page.

Choose the method for creating your new page and assign it a title. If you haven't already made a selection, enter the text for
the link. Click OK.

Browse to Web Page

You can browse to a web page to insert a link by clicking the Browse... button and selecting a page:
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Inserting a link by browsing to a web page.

Notice that you can also type in the name of the page by hand. If you are linking to a page on another web site, the URL must
begin with http://.



Linking to an e-mail Address

To create a link to an e-mail address, simply enter the address in the e-mail Address text field. This type of link is also called a
mailto: link because it provides an address to send an e-mail message to:
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Inserting a link to an e-mail address.

When a visitor clicks on an e-mail link, a new window will open in the visitor's default e-mail client with a new message to that e-
mail address.

Linking to a File on Your Computer

You can link to a file on your computer such as a Word document, spreadsheet or Flash movie. To link to a file on your
computer (My Computer), click the Browse button to select the file.
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Inserting a link to a file on My Computer.




Remember that, when you link to a file on your computer. Contribute will place a copy of that file on the web site when you
publish the draft page.

Note that editing the file on your computer in the future will NOT update the file on the web site. To make sure that changes to a

file will be updated on the web site, choose to edit the file from within Contribute by selecting View > Choose File on Website
from the menu.

Advanced Link Properties

Advanced link properties are easy to understand and give you a little extra flexibility when configuring your links.

Click the Advanced button in the Insert Link dialog to bring up some extra options, as shown here:
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Advanced Link Properties.
These properties are as follows:

e HREF: HREF is the HTML code that represents the URL in the link. You can enter a full URL here or, if you are familiar
with HTML, a relative link. Notice that in our example, hittp://lyn/Contribute/about/index.html is the text that represents
the link in the URL property, but a shorter version, about/index.html, appears in the HREF property. The HREF
property represents a relative link to the page.

e  Section anchor. This allows you to choose from the section anchors available on the page. If any are available, they
will appear in the drop down menu when you click on the down arrow.

e Target frame: This allows you to choose which frame or window the link will open in. Typically, links open in the same
browser window but there are cases where it's desirable to choose a different one. For instance, if you are creating a
link to an outside web site, you may wish to open the link in a new window, rather than send your visitor away from
your own site. We will discuss how to use this property for frames in the Working with Framed Pages section later on.

Modifying Link Properties
You may wish to change the properties of an existing link.
Link Text

To edit the link text, just replace the text as you would with a word processor. Select the text you wish to replace and type the
replacement text.

Link Properties
To edit a link's properties, place your cursor inside the link text or select the linked image and do one of the following:
Right click and select Link Properties

Select Format, Link Properties from the menu
Select the entire link and click the Link button on the toolbar, selecting the appropriate type of link.



Remove Link - . e
To completely remove a link (including the link text/image), simply select the link and press Delete.

i i ight-cli ove Link, or
To remove a link but leave the text or image intact, select the image or text and either Right-click and select Rem ,

Select Format > Remove Link from the menu

Adding and deleting a horizontal rule

You can add horizontal rules to your pages to help organize content. For example, you can use rules to group text
and other elements into topic areas.
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To insert a horizontal rule:
1 Place the insertion point in your draft where you want the horizontal rule to appear.

2 Select Insert > Horizontal Rule.

Contribute inserts the horizontal rule. Content before the insertion point appears above the line, and content after
the insertion point appears below the line.

To delete a horizontal rule:
1 In your draft, click the horizontal rule to select it.

2 Press Delete.

Changing the properties of a horizontal rule

You can customize the height, width, and shading applied to a horizontal rule on a page. By default, a horizontal rule

in Contribute is 3 pixels high, expands to the width of the page or table cell in which it is inserted, and has a small
drop shadow (or shading) applied.

For information about adding and deleting horizontal rules to a page, see “Adding and deleting a horizontal rule” on
page 116.

To set horizontal rule properties:
1 In your draft, click the horizontal rule to select it, and do one of the following:

» Select Format > Horizontal Rule Properties.

+ Right-click (Windows} or Control-click (Macintosh) the horizontal rule, and then select Properties.



The Horizontal Rule Properties dialog box appears.

2 Change options as necessary.

For information about options in the dialog box, click the Help button.
3 Click OK.

Contribute changes the horizontal rule properties.



Saving and Publishing Your Work

Previewing Pages

Save as draft
Save
Send for review to publish
Send email review
Publishing

Rollback



Saving and Publishing Your Work

Before we publish our work, there are a number of things it is advisable to do — we will look at these here.

Previewing Pages

Contribute's Edit mode does a great job showing you how your work will appear, but before you put your edited page out there
for the public to see, you want to be sure that the page appears the way you want it to. The same is true for printed documents.
When you design a document for printing, you should always check that it printed correctly before you distribute it. The Print
Preview function in applications such as Microsoft Word serve the same purpose as Preview in Browser does in Contribute.

To preview your page in your default browser, either Press the F12 key, or Select File > Preview in Browser from the menu.

Saving Drafts

You can save your work at any time during the editing session by pressing Ctrl-S or selecting File > Save from the menu. This
will save the page as a draft. It won't appear on the site until you publish it.

You can also end your editing session without publishing your draft or losing your work. Keep in mind however that, until you
publish or cancel the draft, no one else can open the page for editing. To exit a draft and save it for later either:

Click Browser in the sidebar to switch to Browser view
Select View > Browser from the menu

Press Ctrl-Shift-B on the keyboard

Click the Save For Later button on the toolbar

Select another draft from the sidebar

Create a new page

Exit Contribute

Exiting a draft page without canceling or publishing the draft will save the draft for later.

After you save and exit the draft page, you can reopen the page by selecting it from the sidebar document panel, or navigating
to and opening it in the browser. When you have an unpublished draft of a page you are viewing, click the unpublished draft link
underneath the toolbar to reopen it:

@ You have an unpublished draft of this page.

The unpublished draft link.

e-mail Review

Contribute offers you a way to solicit feedback from others before publishing your draft page by making that page available for
them to view using a special link. The e-mail Review feature generates an e-mail that you can send to those you wish to review
the work. The mail contains a link to the draft, allowing them to comment on the page before it is published.

If the page you send for review happens to be part of a frameset, the link you send will only display the page you send for
review, not the entire frameset. For instance, if you were to edit the bottom or mainFrame in our above example and send that
page for e-mail review, the reviewer will not see the top frame. This can be a problem if the reviewer doesn't understand that
they are viewing only a section of the page as it will appear in the browser, so be clear about this in the accompanying e-mail.
To use e-mail Review, you must be viewing your draft in Edit mode. First, select File > e-mail Review from the menu. The
following dialog may appear:
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If you don't want to see this message in the future, check the Don't warn again checkbox. Click OK to exit it and continue. If
Contribute is able to detect your default e-mail application, it will generate a new message similar to this:
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Sample e-mail review message.

At the same time, Contribute adds this message below the toolbar of your draft page so that you too can view the link as the
reviewer(s) will see it:

@ vou posted a draft fFor review by e-mail on 2/18/2003 11:42 AM, Click here to view the version you posted.

e-mail review link.

Contribute will not generate a review e-mail if it cannot determine your default e-mail application. If this is the case, you can click
the link, copy the URL from your browser and add the link to an e-mail manually.

After you receive feedback from the reviewer(s), you can make the appropriate changes and publish the page.

Publishing Drafts

When you publish a draft page, a number of things happen:

The temporary copy of the page is deleted

The draft replaces the existing page on the web site (unless you publish it as a new page)

Files you have linked to such as images and Flash movies that are currently located on your computer are uploaded to
the server so that they will be available as needed for viewing

If the page is linked to any other new pages, those pages will be published and Contribute will prompt you to give those
pages file names. You can also choose a folder location for the new page

To publish a page either:
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Click the Publish button on the toolbar

Select File > Publish from the menu

Press Ctrl-Shift-P on the keyboard

Select File > Publish as New Page. (You will be prompted to name the new page. Remember that, until you have
created a link to the new page from another page, visitors will not be able to view the page)

The published page appears in Contribute's browser window



Version Roll Back

Depending on the settings configured by your Administrator, Contribute can offer a safety net. You can roll back published
pages to any previous version that is stored on the server. Your Administrator decides how many (up to a maximum of 99)
previous versions of published pages are saved on the web server.

Previous versions of images are not rolled back automatically when you rollback to a previous version of a page. You can
however, roll back to previous versions of images manually, if you launched the image editing software to modify the image from
within Contribute.

To roll back to a previous version of a page:

1. Browse to the page you wish to rollback
2. Select File > Roll Back to Previous Version from the menu, and the following dialog will appear:

Wwe =

Horne Products Support
Products  Support Latest News
» Paintings »
» Framing Knowledge » Painting wins award
Base » Sale on Framing

About Us » FAQs » Press Relgases

T - S R LRt Lo okl T MR A e e o e ol B L e

The Roll Back Page dialog box.

The Roll Back Page dialog box appears. The top section lists the available drafts of the page, including the date and
time published, as well as the person who published the version. The bottom section shows a preview of the version
selected in the top.

3. Select the version you wish to roll back to and verify that it is the desired version in the preview window.
4. Click the Roll Back button, and the version you selected will replace the current page and appear in the Contribute
Browser

The version you rolled back from is also saved as a rollback version, and is made available for you to go back to the next time
you open the Roll Back Page dialog box.



Working with Pages
Creating New Pages

Deleting New Pages



Working with Pages

In this section, we will look at the different methods for creating pages, deleting pages and modifying page properties.

Creating New Pages

Contribute offers several ways to create new pages. Your Administrator can also choose which method(s) of creating new
pages are available to you, if any. The methods available are:

Creating a page based on an already existing page
Creating a page from a pre-defined template
Creating blank pages

Using sample web pages

It is important to keep in mind that, when you create a new page, another page on your site must link to it or visitors to the site
will not be able to see that page. You can choose to create the link automatically when you generate the new page, or add it
later.



Creating a New Page and Adding a Link to it

To create a link to a new page when you create it:

1. Open the page that will contain the link for editing using one of the methods discussed earlier
2. Put your cursor where you want the link to appear then select text for the link, or select an image for the link. (We'll
discuss adding links in more detail later on in the Working with Links section.)

3. Click the Link button on the toolbar and select Create New Page, or use the menu and choose Insert > Link > Create
New Page:
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Inserting a link into a new page.

The Insert Link dialog appears. Note that Create New Page is highlighted in the top bar.

4. Provide a title for the new page.

5. Continue with the steps for your chosen method for creating the new page. Remember that the methods available to
you depend on the permissions your Administrator has granted your User group.

Creating a New Page without Linking to it

You may choose to create a page without linking to it if you don't want to make it available to the public immediately. To do so,
choose one of the following methods:

¢ In either Edit or Browser mode, choose File > New Page from the menu
e Press Ctrl-N on your keyboard

* In Browser mode, click the New Page button on the toolbar

The New Page dialog box appears, as shown:
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The New Page dialog box.

Provide a title for the page and select the method you wish to use to create a new page, from the methods your Administrator
has made available to you. Any options that are grayed out are not available.

Creating a Page from a Pre-Defined Template

If your Administrator has provided any Dreamweaver template pages for you to create new pages from, they will appear in the
New Page dialog box.

1. Select the template you want to use for the new page. Use the Preview window to confirm you have selected the
correct page

Make sure you've provided a page title

Click OK

A new page based on the selected template will open for editing

hON

It's important to note that working on pages based on Dreamweaver templates is a little different from working plain HTML
pages. Your webmaster has created the templates to maintain a consistent look and navigation structure throughout the site
and can restrict the areas of the page available for you to edit.

Deleting Pages

Your Administrator may have given you permission to delete files. Before you do, remember that deleting a page or image can
result in a broken link. Make very sure that deleting a file won't cause problems before you do so.

To delete a published page, you can either choose the page to delete in Browser Mode, using any of the same methods used
for selecting a page to edit that we discussed above, or choose File > D_elete Page from the menu. .

if you have an open draft of the page you wish to delete, cancel or publish the draft pefore you selec_:t the page in Browser
mode. You may delete any new page that you have as a Draft but have not yet published by canceling the Draft.



Where to go for More Help

Regardless of how thoroughly you prepare to use Contribute, issues will doubtless come up that you have not been exposed to
or don't remember how to handle. There are a few places you can go for help for issues that arise:

e The How Do |... panel in the sidebar
e The Help menu (which can also be accessed by pressing F1 on your keyboard)
e  Your Administrator

Summary

So that's it, we've reached the end of the glasshaus Contribute End-User Training Guide. We hope this document has provided
you with all you need to use Contribute efficiently and successfully. Keep a printed copy nearby at all times and you shouldn't go
far wrong.






