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IMPORTING TEXT FILES

1. Click the Data tab, select From Text
2. Locate the file and click import
3. The Text Import Wizard will appear

Text Import Wizard

1. Choose the file type that describes your data. If you are unsure of the type leave the default
settings > Click Next

e Delimited — information separated by characters such as commas or tabs
e Fixed with — information separated by spaces between each file

[2]x]

The Text Wizard has determined that your data is Delimited.

If this is correct, choose Next, or choose the data type that best describes your data.
Original data type
Choose the file type that best describes your data:

(®) Delimited - Characters such as commas or tabs separate each field.
() Fixed width - Fields are aligned in columns with spaces between each field,
Start import at row: \17 ] 3 File origin: 437 : OEM United States v

Preview of file C:\Documents and SettingsitthomasiMy Docum...\Managing data XP.txt.

RankOSexOFirst NameOLast Name OSalaryODepartment S
bssociate ProfessorOF00prahlWinfrey O0"$90,000.00"0Conmunication
bssociate Professor0F0GwenOStefaniO"$56,222.00"0Vocal

hssociate ProfessorOMOMichealOJordanO"$89,000.00"0Athletics
bssociate ProfessorOMOBillOCosby0"$56,000.00"0Conmunications
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2. Select the delimiter(s) your data contains, if you are unsure leave the default. > Click Next
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Text Import Wizard - Step 2 of 3 12 [t
This screen lets you set the delimiters your data contains. You can see how your text is affected in the preview
below.

Delimiters

Tab

[ semicalon Treat consecutive delimiters az ane
Comma

S ; ext gualifier: |~ IZI
Space

7] other:

Data preview
ank lFex [First Name [Last Name [Salary epartment &
ssociate Professor |F Porah Hinfrey lF90,000.00 ommunications ([ |
ssocciate Professcr [ [Fwen Etefani F58,222.00 [oczl
Ssociate Professcor M Micheal Hordan I58%5,000.00 thletics
ssociate Professor M Pill Cosby I5&,000.00 ommunications -
4| i | 3
Cancel | | <gack | [THext>"7 | Einish




3. Select a format for each column. To select a column, click on the column headers

-

Text Import Wizard - Step 3 of 3

Pl X

This

@ General
@) Text
) Date:

Column data format

MDY
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column and set the Data Format.

General' converts numeric values to numbers, date values to dates, and all

emaining values to text.

") Do not import column (skip)

\

Data preview

Column Headers

l

epnersl eperal epers] epersl

First Hame [Lzst Hame [Salary Pepertment

Cprah infrey F90,000.00 Kommunications

[Fwen tefani F5e,222.00 [ocsl

Michezal ordan F85,000.00 PRthletics

Bill oaby F5e,000.00 [Communications

I I
Cancel l [ < Back

4. Click Finish
5. Select where you want to place your data
; Import Data |_?__§Z_r

Where do you want to put the data?
@) Existing worksheet:
=SAS1
(") New worksheet

[ Properties... ] [ OK

]{ Cancel ]




CREATING A TABLE

When creating a table in Excel keep the following in mind:
e Create the table on one spreadsheet

e Create column headers at the top of each column
a. Inthe example below the column headers are: Rank, First Name, and Last Name
Note: Try not to leave any blank rows or columns but you may have blank cells.

A B [
1 |Rank First Name Last Name
2 Associate Professor Oprah Winfrey
3 | Associate Professor | Gwen Stefani
4 |Agsociate Professor Micheal Jordan
5 |Associate Professor Bill Cosby
G | Doctor Robert Redford
7 Dactar Salma Hayek
5 Doctor Jules Asner
9 Doctaor hlatt LeBlanc
10 |Professor F Diddy
11 |Professor Sandra Bullock
12 |Professor hlatt Diarnon
13 |Professor Jeff Soldblum

Range: Two or more cells on a sheet. The cells in a range can be adjacent or nonadjacent.

Table: A series of rows and columns that contains related data that is managed independently from
the data in other rows and columns on the worksheet.

Creating a table from predefined data
1. Select the contents of your range
2. Select the Insert Tab > Select Table in the Tables group
3. Click OK to the Create Table box

Create Table ‘L&

Where is the data for your table?

|| My table has headers

OK ]1 Cancel ]

[S 4

Creating a new table
1. Select the range of cells to be included in the table
2. Click the Insert Tab > click Table in the Tables group
3, Clle Ok ’Crc-ateTabIe ‘@AX“

Where is the data for your table?
=SAS19:SES32

E3)

|¥] My table has headers

{ OK ][ Cancel ]

[ 4

Note: You can create multiple tables on one spreadsheet



TABLE MANIPULATION
Design Tab

This tab will only display when a table is active.

Table Name: [i3] Summarize with PivotTable j Propertie [¥] Header Row [C] First Column EEEEE e i S .

Tablel }'Remove puplicates || ® = W openinBrowser || [l TotalRow [ LastColumn  |||[EEc=c) Emmmmll= o= =S| S==22 SZESZ 22225 S22

| T Resize Table | .;] Convert to Range H ¢ H [¥] Banded Rows [] Banded Columns Il
1 | | | |
Properties Group:
e Table Name: Give the Table a name if you plan to use it in future formulas
e Resize Table: Add/Remove columns and rows

Export Refresh

Tools Group:
e Summarize with PivotTable
e Remove Duplicates- Remove duplicate rows from a sheet
e Convert to Range — Converts table into a normal range of cells

Table Style Options:
Header Row
Total Row
Banded Rows
First Column
Last Column
Banded Columns

Table Style
e Change the color styles of the table

Total Row
This row provides access to summary functions so that you can quickly calculate your data.

Turning on the Total Row

H | J K s M
1. Select the last row of your table [Fall  ElWinter B Spring ) Summer B
2. Right-Click in the last row > Click Table > Click o - — o
Total Rows 46 34 67 100
20 32 78 78
98 56 89 88
86 67 aial ~[12 A A S % 2 F
61 s BIED-> A -WAE
78 12 o o —
78 23 % | cut :
53 Copy
fall B winter B eteio
Insert »
Delete >
Select >
Clear Contents
Sort >
Filter »
(Z] Totals Row Table >
Conyert to Range | Insert Comment
[&f Format Cells...
Pick From Drop-down List...
&, Hyperlink...

[T Total Row [ tastColumn ||| === == === —— | —— = ——— = ———— . ————— ————— -



AUTO FILL

Use the Auto fill feature to fill cells with data that follow a certain sequence.

Numbers
Auto filling a sequence of numbers:
1. Type the first two numbers in the sequence
2. Highlight those two numbers
3. Click the Auto fill handle (lower right hand corner of the cell) and drag down

Auto filling a series:
1. Type the first couple of characters of the sequence.
2. Hold down the control key on your keyboard and the Auto fill handle then drag down

Dates
Auto filling a sequence of dates:
1. Type in the first date in the sequence
2. Click on the Auto fill handle (lower right hand corner of the cell) and drag down

Auto Fill handle

Custom Lists

Click the File tab > Click Options

Click Advanced

Under the General section, click Edit Custom Lists

Click in the List Entries section and type your list, hit enter after each entry
Click Add

Click Ok twice

OuhsWNE



SORTING & FILTERING
Sorting:
Sorting one column
1. Click the down arrow, located in the column header, of the column to be sorted
2. Select the Sort order, ascending (a-z) or descending (z-a)

Sorting multiple columns - You can sort up to 64 fields at one time

Click the Data tab > in the Sort & Filter group click Sort

Click Add Level to add additional levels

Under Column select the fields you want to sort

Under Sort On select one of the following: values, cell color, font color, cell icon
Under Order select the sort order, ascending (a-z) or descending (z-a)

arwnE

Sort - (9] = ]

W
1] Add Level H X Delete Level “ 53 Copy Level ” : My data has headers

Column Sort On Order
Sortby |Rank [¥] values (=] |Atoz

Thenby | pepartment E} Values E} AtoZ

=]
=]

oK ] [ Cancel




Filtering:
1. Click the down arrow in the column that is to be filtered
2. Check off the condition you want to filter
e Depending on the size of your list it may be better to check off the “Select All” option first
then select your filter criteria.
e You can filter more then one field.
3. Click Ok

C=_La

D Home Page Layout Formulas Data Review View Add-Ins ) e = BB
o= ™y H— 0 =
G EED® o xSl vxun 5 @ HE 4 Fd TQ
PivotTable Table  Picture Clip Shapes SmartArt Screenshot | Column  Line Pie Bar  Area Scatter Other Line Column Win/Loss | Slicer | Hyperlink | Text Header WordArt Signature Object | Equation Symbol
< Art 5 < 5 < < < < < Charts ~ Box & Footer < Line - <
Tables Illustrations Charts Sparklines Filter Links Text Symbaols
| H17 - £ v
= G H I ] K L M N o 3 s
1 [ENIS |
4] soratez Winfrey $90,000.00 Communications
%l sortzton Stefani $56,222.00 Vocal
Sort by Color v Jordan $89,000.00 Athletics
Cosby $56,000.00 Communications
Mullally 50,000.00 Drama
Conery $45,985.00 Mathematics
Text Biiters " | Presley $55,459.00 Art
[search Pl allen 485,000.00 Biology
-] (Select All Arquette $42,396.00 Marketing
i.[] Assodate Professor Baldwin $50,000.00 Finance
857 Doctor | Cage $19,995.00 Biology
+LProfessor Diddy $230,000.00 Vocal
Bullock $45,689.00 Political Science
Damon §124,578.00 Political Science
Goldblum $78,900.00 Physics
Hayes 102,000.00 Management I _I
McCormack 89,995.00 Art
Roberts §93,500.00 Comp-uterScience L
Anthony $75,005.00 Chemistry

Example: The above example has all Doctors filtered out of the list.

Custom Filters:
1. Click the down arrow in the column you want to filter
2. Select Text Filters or Number Filters (this will depend on what you are trying to filter)
3. Enter the parameters for your filter

Custom AutoFilter
Show rows where:
Salary
llequals v | i e |
®and Oor
v | vl

Use ? to represent any single character
Use * ta represent any series of characters

[ OK ] [ Cancel

Turn off the filter:
1. Click the down arrow in the column where the filter has been applied
2. Select Clear Filter




DATA VALIDATION

You can use data validation to define restrictions on what data can or should be entered in a cell.

Adding Data Validation to a cell
1. Select the cell you want to validate
2. Select the Data Tab and in the Data Tools Group select Data Validation

Settings Tab
1. On the Settings tab, under Allow, select the type of criteria you want to allow in the cell. Under
Data enter in the excepted values

T o]
Data Validation liAil
Settings | Input Message ] Error Alert |
Validation criteria
Allow:
Whole number B [¥] 1gnore blank
Data:
between EI
Minimum:
Maximum:
[] Apply these changes to all other cells with the same settings
Clear Al ] [ OK ] [ Cancel
2. Click Ok

Data validating from an existing list
1. Select List under the Allow box
2. Type your values in the source box, placing commas after each selection OR if you currently
have a list in your worksheet, go back to the worksheet and select the list

Input Message Tab- Used to create helpful messages for validated cells.

1. Type in a title for the message
2. Type in a message, your message should indicate a reason or a brief explanation for the
validation or restriction

Data Validation ? P

-

‘ Settings | InputMessage | Error Alert \

[¥] Show input message when cell is selected

When cell is selected, show this input message:
Title:

Input message:

& ] o




Error Alert Tab - Used to create an alert when invalid data is entered.

Data Validation lii‘

‘ Settings I Input Message “ Error Alert

[¥] show error alert after invalid data is entered

When user enters invalid data, show this error alert:
Style: Title:

Stop E]

Error message:

‘8

| Clear All OK I[ Cancel

1. Select your style
a. Stop — Allows the user to select Retry or Cancel

b. Warning — Allows the user to click Yes to accept the invalid entry, No to edit the invalid
entry, or Cancel to remove the invalid entry

c. Information — This is the most flexible alert, this allows the user to click OK to accept
the invalid value or Cancel to reject it

2. Enter atitle and an error message



DATA MANIPULATION FUNCTIONS

Concatenate Function — Joins several text strings into one.

1. Select the cell were the consolidate date will be entered
2. Click the Formulas tab — select Text — select Concatenate

B3 AT
[} Home Insert Page Layout Formulas Data Review View Add-Ins

fFIpeadie as@ S,

Insert AutoSum Recently Financial Logical | Text |Date & Lookup & Math More Name

Function = Used ~ = = = Time » Reference = & Trig = Functions * | Manager B
Functio BAHTTEXT L
| HI7 e £ CHAR
A B = CLEAM E F
1 coo
2  Associate Professor F Oprah 0,000.00 Communications
3 Associate Professor F Gwen 65,222.00 Vocal
4 Associate Professor M Micheal DOLLAR 9,000.00 Athletics
5 Associate Professor M Bill EXACT 6,000.00 Communications
6 Associate Professor F Megan FIND 30,000.00 Drama
7 Associate Professor M Sean - 5,985.00 Mathematics
3 Associate Professor F Lisa M. 5,459.00 Art
9 |Associate Professor M Tim LET 5,000.00 Biology
10 Associate Professor M David LEN 2,396.00 Marketing
11 Associate Professor M Alec LOWER 0,000.00 Finance
12 Associate Professor M Nicholas MID 9,995.00 Biology
13 Professor M P ROPER 0,000.00 Vocal
14 Professor F Sandra 5,689.00 Political Science
15 professor M Matt REFLACE 4,578.00 Political Science
16 Professor M Jeff REFT 8,900.00 Physics
17 Professor M Sean RIGHT 02,000.00 Management
18 Professor M Eric SEARCH 39,995.00 Art
19 Professor F Julia SUBSTITUTE 3,500.00 Computer Science
20 Professor M Marc 5,005.00 Chemistry
21 Professor M Tim T 9,956.00 Marketing
22 Professor F Faith TEXT 8,500.00 Drama
23 Professor F Celine TRIM 0,650.00 Art
24 Professor M Ed UPPER 9,599.00 Physics
25 Professor F Demi VALUE 9,568.00 Computer Science
26 Doctor M Robert 5,800.00 Athletics
27 Doctor F Salma | f* InsetBundion.. L ono 00 prama

3. In the Function Arguments window, click in the Textl box and enter the cell reference for the
first part of the string and in the Text2 box enter the cell reference for the second part. You
can add up to 255 text strings.

a. You must specify any spaces or punctuation that you want to appear in the results by
using quotation marks in the appropriate Text box.

Ex: Function Arguments TS
’ CONCATENATE
- Textl A2 “Professor™ -

The quotes supplied put a space - - o

between first and last text string.
Text3 |C2 "Roberts™
Textd =" =he
Text5 =

= “Professor Roberts *
Joins several text strings into one text string.

Text5: textl,text2,... are 1to 255 text strings to be joined into a single text string
and can be text strings, numbers, or single-cell references.

Formula result = Professor Roberts

Help on this function OK ] [ Cancel

10



W e

Use the Fill Handle in the lower right hand corner of the cell to apply the function to the

remainder of the list. 3
B — Auto Fill handle

To remove the link between the referenced cells
Highlight the row with the concatenated data

Select Copy

Select the down arrow under Paste and select Paste Values

Left and Right Function - These two functions are used to split text. Use the Left function to split
out characters on the left and use the Right function to split our characters on the right.

WhNpEes » wWNhEe

s

Left Function

Select the cell where the information will be entered

Select the Formulas tab — select Text — select Left

In the Function Arguments window, place the cell reference of the text string in the Text box.
Then in the Num_chars box type the number of characters you want to extract from the left.
Click Ok

Right Function

Select the cell where the information will be entered

Select the Formulas tab — select Text — select Right

In the Function Arguments window, place the cell reference of the text string in the Text box.
Then in the Num_chars box type the number of characters you want to extract from the right.
Click Ok

Adding additional characters

In the formula bar type the ampersand (&) in between the functions

ROW function - This function will return the number of the row that you reference. Ex: =ROW(A1)
returns the number 1.

1. Select the cell where the numbering will start and type =ROW/(A1)
2. Drag the fill handle down or across the range you want to fill.

RANDBETWEEN function — Returns a random set of numbers

rwnhE

Select the cell where the information will be entered

Select the Formulas tab — select Math & Trig — select RANDBETWEEN
Enter your bottom and Top numbers

Click Ok

11



